bnds.net
当前位置:首页 >> CEntos gD liBrAry >>

CEntos gD liBrAry

> --with-zlib=/usr/local/zlib/ \ > --with-jpeg=/usr/local/jpeg6/ \ > --with-png=/usr/local/libpng/ \ > --with-freetype=/usr/local/freetype 首先确定这4个包是否正常安装 其次要再多安装两个软件 libxml2、libmcrypt

看下是不是需要把/usr/local/libgd/lib这个目录放到环境变量中 LD_LIBRARY_PATH 这个环境变量中

从字面意思上像是gd的扩展库 yum -y install gd-devel libjpeg-devel libpng-devel php-gd libjpeg* libpng* freetype* gd* 找到了几个关于图片的几个扩展,不如一次性装好,看看gd能不能用好。

应该是gd没装上吧 安装gd tar zxvf gd-2.0.33.tar.gz cd gd-2.0.33 CPPFLAGS="-I/usr/local/freetype2/include -I/usr/local/jpeg8/include -I/usr/local/libpng2/include -I/usr/local/fontconfig/include" ./configure --prefix=/usr/local/gd...

这个一般是你系统里以前装过其他版本的php的公共包没卸载干净导致的,我建议你先试试它建议你的加个 --skip-broken参数试试。运气好就装上了,运气差得话,那估摸着要源码装或者重装系统

原因:php没有找到动态库文件 解决方法: 看下该模块是否已经安装,可以去/usr/local/php5/lib/php/extensions/no-debug-zts-20060613 看下有没有zip.so 不知道怎么安装扩展的话百度下“安装php扩展”

配置APR安装目录 configure这一步一般用来生成 Makefile,为下一步的编译做准备,可以通过在 configure 后加上参数来对安装进行控制 --prefix : 设置安装目录 ./configure --prefix=/usr/local/apr 开始编译APR make编译,大多数的源代码包都经...

开启GD库支持有以下几种方法 检测GD库是否安装命令 php5 -m grep -i gd 或者 php -i grep -i --color gd如未安装GD库,则为服务器安装,方法如下 如果是源码安装,则加入参数 --with-gd 如果是debian系的linux系统,用apt-get安装,如下 apt-get...

目前你的gd版本过低,请先升级你的gd

不妨试试:缺少编译安装的软件包。如:yum install automake,libjpeg-devel,libpng-devel,freetype-devel,libtiff-devel,autoconf,gettext-devel,libtool

网站首页 | 网站地图
All rights reserved Powered by www.bnds.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com